首页 > 数据库技术 > 详细

mongodb.open is not a function

时间:2018-01-31 16:56:03      阅读:1651      评论:0      收藏:0      [点我收藏+]

标签:mod   com   clas   not   install   gpo   需要   all   ins   

用node.js连接MongoDB数据时,想在数据库中写入数据,却显示mongodb.collection不是一个函数。

这个错误是出在mongodb的库中,只需要把node_modules中mongodb的版本换为2.2.33vision即可解决。

先在package.json文件中改掉mongodb的版本:

技术分享图片

然后再npm install 一下,就可以了。

mongodb.open is not a function

标签:mod   com   clas   not   install   gpo   需要   all   ins   

原文:https://www.cnblogs.com/niyi/p/8393175.html

(0)
(0)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
© 2014 designnerd.net 版权所有 鲁ICP备09046678号-4
打开技术之扣,分享程序人生!
             

鲁公网安备 37021202000002号